Uses of Class
org.jruby.CompatVersion

Packages that use CompatVersion
org.jruby   
org.jruby.embed   
org.jruby.parser   
 

Uses of CompatVersion in org.jruby
 

Methods in org.jruby that return CompatVersion
 CompatVersion RubyInstanceConfig.getCompatVersion()
           
static CompatVersion CompatVersion.getVersionFromString(java.lang.String compatString)
           
static CompatVersion CompatVersion.valueOf(java.lang.String name)
          Returns the enum constant of this type with the specified name.
static CompatVersion[] CompatVersion.values()
          Returns an array containing the constants of this enum type, in the order they're declared.
 

Methods in org.jruby with parameters of type CompatVersion
 void RubyInstanceConfig.setCompatVersion(CompatVersion compatVersion)
           
 

Uses of CompatVersion in org.jruby.embed
 

Methods in org.jruby.embed that return CompatVersion
 CompatVersion EmbedRubyInstanceConfigAdapter.getCompatVersion()
          Returns a Ruby version currently chosen, which is one of CompatVersion.RUBY1_8, CompatVersion.RUBY1_9, or CompatVersion.BOTH.
 CompatVersion ScriptingContainer.getCompatVersion()
          Returns a Ruby version currently chosen, which is one of CompatVersion.RUBY1_8, CompatVersion.RUBY1_9, or CompatVersion.BOTH.
 

Methods in org.jruby.embed with parameters of type CompatVersion
 void EmbedRubyInstanceConfigAdapter.setCompatVersion(CompatVersion version)
          Changes a Ruby version to be evaluated into one of CompatVersion.RUBY1_8, CompatVersion.RUBY1_9, or CompatVersion.BOTH.
 void ScriptingContainer.setCompatVersion(CompatVersion version)
          Changes a Ruby version to be evaluated into one of CompatVersion.RUBY1_8, CompatVersion.RUBY1_9, or CompatVersion.BOTH.
 

Uses of CompatVersion in org.jruby.parser
 

Methods in org.jruby.parser that return CompatVersion
 CompatVersion ParserConfiguration.getVersion()
          Get the compatibility version we're targeting with this parse.
 

Methods in org.jruby.parser with parameters of type CompatVersion
 RubyParser RubyParserPool.borrowParser(CompatVersion version)
           
 

Constructors in org.jruby.parser with parameters of type CompatVersion
ParserConfiguration(Ruby runtime, int lineNumber, boolean extraPositionInformation, boolean inlineSource, boolean isFileParse, CompatVersion version, boolean saveData)
           
ParserConfiguration(Ruby runtime, int lineNumber, boolean extraPositionInformation, boolean inlineSource, CompatVersion version)
           
ParserConfiguration(Ruby runtime, int lineNumber, boolean inlineSource, CompatVersion version)
           
 



Copyright © 2002-2009 JRuby Team. All Rights Reserved.